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Descriptor 
This guide describes the capabilities and methods of integrating Tranxition 
Migrate7™ user state migration with Microsoft System Center Configuration 
Manager 2007 R2. 



 

Table of Contents 
Introduction ................................................................................................. 3 

Audience ................................................................................................ 3 
Prior Knowledge ...................................................................................... 3 

Benefits of Integration ................................................................................ 4 
Architecture Concepts ................................................................................... 5 
Getting Started ............................................................................................ 7 

Prerequisites ............................................................................................. 7 
Preparing the Migrate7 Environment ............................................................. 7 

Install Migrate7 ....................................................................................... 7 
Create Data Store/s ................................................................................. 9 
Create User Migration Template/s ............................................................ 11 

Deploying Migrate7 with SCCM ..................................................................... 12 
Prerequisites ........................................................................................... 12 
Deployment Step-by-step ......................................................................... 12 

Create Migrate7 Agent Source ................................................................. 12 
Create Migrate7 Agent Package ............................................................... 13 
Create User Profile Extraction Package ..................................................... 15 
Create User Profile Backup Package ......................................................... 17 
Confirming Deployment/s ....................................................................... 20 

Deployment Tips ...................................................................................... 21 
Migrate7 Agent Logging ......................................................................... 21 
Assessing Migrate7 with DCM .................................................................. 21 

Integrating Migrate7 with SCCM OSD and MDT ............................................... 22 
Prerequisites ........................................................................................... 22 
Adding Migrate7 client to your existing OSD task sequences .......................... 22 

Auto Extract User Profiles Task Sequence – Existing Task Sequence ............. 23 
Auto Extract User Profiles Task Sequence – New Task Sequence .................. 23 
Auto Inject User Profile Task Sequence – Existing Task Sequence ................ 24 
Auto Inject User Profiles Task Sequence – New Task Sequence .................... 25 
Auto Backup User Profile Task Sequence – Existing Task Sequence .............. 26 
Auto Backup User Profiles Task Sequence – New Task Sequence .................. 26 

Advanced User Profile Migration ................................................................. 28 
Additional Resources ................................................................................... 29 
Command Line Argument Quick Reference ..................................................... 30 
COPYRIGHT AND PATENT INFORMATION ........................................................ 31 
 
  

 
Integrating Migrate7 with System Center Configuration Manger 2007 R2                                    Page 2 of 31 



Introduction 
Migrate7 is a desktop management tool designed to help IT professionals migrate 
and store PC user states (data, application and OS settings), for example when 
moving hundreds or thousands of desktops from Windows XP to Windows 7. 

Migrate7 automatically extracts and preserves end-user customizations, metadata 
and files ("user state") from desktops and moves them to new or upgraded 
desktops or virtual images. Set up migrations using a graphical user interface to 
determine which applications and files to preserve and transfer. Easily customize to 
conform to company policies and customer preferences. Migrate7 can also be used 
as ongoing user state backup to enable ad-hoc PC replacement and data recovery. 

Microsoft System Center Configuration Manager 2007 R2 is the solution for 
comprehensively assessing, deploying, and updating your servers, clients, and 
devices across physical, virtual, distributed, and mobile environments. Optimized 
for Windows desktop and Windows server platforms, it is the best choice for 
centralizing management from the data center to the desktop. 

Using Configuration Manager’s software distribution functionality, Migrate7 can be 
delivered to machines and configured to automate user profile extraction, backups, 
and restores. Combined these solutions provide a more robust migration and 
deployment solution. 

Note: Throughout this document, the term “Configuration Manager” is used to refer 
to Microsoft System Center Configuration Manager 2007 R2, and the term 
“Migrate7” is used to refer to Tranxition’s Migrate7 user management tool. 

Audience 
This document is intended for IT administrators who are interested in using 
Configuration Manager to deploy Migrate7 to client PCs and automating the 
extraction and refresh of user profiles.  It provides a technical overview of the 
integration of Configuration Manager 2007 R2 and Migrate7, and describes how to 
configure and use a Configuration Manager infrastructure to deploy and manage 
Migrate7. 

Prior Knowledge 
The administrator using this guide should have previous knowledge of the following 
technologies: 

• System Center Configuration Manager 2007 
• Tranxition Migrate7 
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Benefits of Integration 

Configuration Manager R2 offers a rich set of capabilities that enterprises can 
leverage for managing and utilizing Migrate7. Integrating Migrate7 with 
Configuration Manager provides the following benefits to end users:  

• Infrastructure –Enterprises can leverage Configuration Manager to manage 
all of their Migrate7 management tasks. Migrate7 integration with 
Configuration Manager provides enhanced capabilities including user 
targeting, ease of deployment, quick application installation process, and 
dynamic task sequencing of user state migration tasks.  

• Scalability – Users can leverage Configuration Manager Distribution Points 
for hosting the Migrate7 data store, thus removing the need to deploy and 
maintain a separate Migrate7 data store.   

• Operating System Deployment – By leveraging Configuration Manager’s 
operating system deployment feature, customers can deploy Migrate7 as part 
of the process of installing the OS as well as automatically migrate user data, 
thereby reducing the time required to get a new system up and running for 
an end user.  

• Automated User Backups – With the integration with Configuration 
Manager, a Migrate7 client can extract users’ data store/s on a routine basis 
providing user state snapshots automatically through the use of 
Configuration Manager collections and advertisements. 

• Automated User State Migration – Migrate7 automates the backup, 
restoration, and management of user state profiles offering several 
capabilities not available within USMT, including: 

o Graphical user interface for configuring user migration profiles, 
including advanced UI for managing files and registry rules 

o Ability to convert legacy application settings to current version and 
migrate user profiles based on roles and business groupings 

o Ability to migrate user states from, to, and between all versions of: 
Windows 2000, 2003, Windows XP, Vista, and Windows7 

Through using this guide to integrate Migrate7 with SCCM users will be able to 
automatically deploy and maintain Migrate7 agents to client endpoints (note agent-
less option available as of v7.5); and automatically manage user profile backup, 
restores, and migrations with SCCM OSD and MDT 
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Architecture Concepts 
Migrate7 provides a centralized, graphical, wizard-driven solution to automate user 
state profile migrations, backups, and restores. The solution architecture consists of 
a central data store or stores that maintain folders for each user personality 
managed. Migrate7 can be configured and administered via the client console to 
manage user profile configurations and user state migration activities which can 
also be automated with command lines. The diagram below illustrates the basic 
architecture of the Migrate7 solution. 

Data
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Desktop Personality

Extract / Backup
Inject / Restore

Run from local or remote 
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For more details on the Migrate7 architecture and automating processes with 
command line options please see the Migrate7 User Guide and Migrate7 Automation 
Guide listed in the references section at the end of this guide.  
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The Migrate7 solution can be fully integrated with SCCM to augment and/or replace 
USMT to provide more robust user state management capabilities. When planning 
to integrate Migrate7 with SCCM, a few considerations should be taken to prepare. 

1. Will we have a single Migrate7 data store for business?  
2. Should the data store be a dedicated resource or an existing SCCM resource?  
3. Should we do local stores on each client vs. network share? 
4. How many unique user state configuration files will we need to create to 

support the various profiles? 
5. Should we allow users to access the Migrate7 client from their desktop? 
6. Do we want to extract/backup all local user state profiles, only the logged in 

user, or only ones that have been used? Do we want to exclude any users? 
7. Do we need to password protect the personalities within the Data Stores/s? 

 

Once these questions and the general design have been planned out Migrate7 can 
be deployed and managed with SCCM. SCCM can be used to deploy and configure 
the Migrate7 client to target machines plus deploy packages with agent command 
line switches to initiate user state activities. While all of this is accomplished with 
standard SCCM packages, collections, and advertisements, the Migrate7 Data 
Store/s do need to be set up in advance and a user migration template must be 
created. The number of Data Stores directly impacts the complexity of automating 
user state migration but does enable support for a broad range of SCCM 
configuration scenarios. The diagram below shows a vanilla SCCM architecture with 
a single Migrate7 Data Store.  
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Getting Started 
This section provides instructions for preparing the Migrate7 environment to then 
integrate with SCCM.  

If you already have an existing Migrate7 environment you can skip this section and 
proceed to ‘Deploying Migrate7 with SCCM’ on page 9. 

Prerequisites 
The following assets and preparation are required to successfully integrate Migrate7 
with SCCM, they include: 

1. Migrate7 software 

2. Sufficient privileges to install software and create/access Data Store 

Preparing the Migrate7 Environment 
To prepare Migrate7 for integration with SCCM there are three primary steps that 
need to be completed. 

1. Install Migrate7 

2. Create Data Store/s 

3. Create User Migration Templates 

Install Migrate7 

Migrate7 installs two components - the Server and the Client. The Server contains 
the Client installation files and the reference files for migrating application settings. 
The Client component is automatically installed and invoked when the SCCM 
package is distributed. The Migrate7 Client acts as the agent to facilitate the 
personality extraction, backup and injection processes.  
 
For the purpose of this document, Migrate7 Server should be installed on an 
established SCCM Server; typically this is done on a dedicated Server or 
Distribution Point. For more information on the Migrate7 Server installation and the 
Data Store, see the Migrate7 Deployment Guide included in the Migrate7 
installation.  
 
The following steps install the Migrate7 files, directories and agents on the device 
established as the Server, and install the Migrate7 Client agent on the machine that 
will be used to configure the migration templates.  
 

1. Run the file ServerSetupLM.exe from your Migrate7 CD or your extracted 
zip file location. This will start the Migrate7 Server installation wizard.  

2. On the Welcome screen, click Next.  
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3. On the License Agreement screen, read the agreement and click I Accept to 
continue.  

4. On the Registration screen, enter the administrator’s name, company name, 
and Migrate7 serial number. Then click Next.  

5. On the Choose Destination Location screen, click Next to install to the 
default location C:\Migrate7 Installation, or the browse button to select an 
alternate location to install the Server.  

6. Wait for the Migrate7 Server files to install.  

7. On the Installation Complete screen, select Install Client and click Finish.  

8. This will close the Migrate7 Server installation and launch the Migrate7 Client 
setup wizard.  

9. On Welcome screen, click Next.  

10.On the Choose Destination Location screen leave at default, click Next.  

11.On the Select Program Manager Group screen, select the desired program 
group or simply click Next to accept the default.  

12.Wait for the Migrate7 Client to install.  

13.When the Desktop Shortcut dialog appears, click Yes.  

14.On the ReadMe File screen, click OK.  

15.On the Installation Complete screen, click Finish.  

The Migrate7 Server and Client components are now installed. 
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Create Data Store/s 
The Migrate7 User State Data Store Setup serves as the central location where 
personalities and configuration information will be stored as well as the installation 
source for the Migrate7 client.  When you use SCCM to deploy Migrate7 software, 
you set up the source user profile directory with the Migrate7 User State Data Store 
Setup utility.  

When using Configuration Manager to deploy the Migrate7 client, we recommend 
creating a client source directory on your site server/s to decrease the size of the 
Migrate7 installation package. The location where you perform the administrative 
installation becomes the location of the package source directory. 

The account performing file backups or personality restores must have full access to 
the Data Store shared folder. If Migrate7 is launched and managed through a SCCM 
2007 service account, only that account will need these rights.  
 

Note: Personality Protection - In many cases, users will need to 
access their personality to use Migrate7’s Restore Files 
functionality. To prevent users from accessing other personalities, 
each stored personality should be password protected. This can be 
done automatically by using the /Password command line switch or 
by setting the appropriate policy in the Migrate7 configuration. The 
/Password command is generic for a cfg file and not unique per 
personality, when automating through SCCM this could be used to 
ensure only the service account is extracting/injecting stored 
personalities.  

Data Store folder and specifying security privileges:  
The following steps assume the Server is installed in the default location of 
C:\Migrate7 Installation. If another installation location was specified, substitute 
“C:” below with the alternate Server location you selected.  
 

1. From the system where the Migrate7 Server was installed open My 
Computer.  

2. Double-click C:  

3. Find the folder called Migrate7 Installation. Right-click on the folder and 
select Sharing and Security….  

4. The Migrate7 Installation Properties dialog appears with the Sharing tab 
selected.  

5. On the Sharing tab, select the radio button Share this folder.  
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6. In the Share name field, specify a share name for the folder. This guide 
assumes the share name is Migrate7.  

7. Press the Permissions… button.  

8. The Permissions for Migrate7 Installation dialog appears.  

9. Confirm that users running Migrate7 have Full Control of the Migrate7 
Server.  

10.Click OK.  

11.Select the Security tab.  

12.Under Group or user names specify Full Control for each users or groups 
running Migrate7.  

13.Click OK.  

The Migrate7 Data Store has now been created. To learn more about deployments 
and setting up the source directory for Migrate7 software, reference the Migrate7 
Deployment Guide. 
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Create User Migration Template/s 
A Migrate7 configuration consists of three files:  
 

1. The .rul file contains the File Rules  

2. The .ptt file contains a list of the selected application content.  

3. The .cfg file contains any changed policies, Registry Rules, and the location of 
the Data Store.  

Tip: You can create migration templates for different profiles, 
desktop roles, and data stores. You must have one template 
defined prior to automating user state migration tasks with SCCM. 

Migrate7 creates the three files automatically when a user migration configuration 
is saved. All files must have the same name and be in the same folder for your 
configuration to execute successfully. By default, the files are named SE (SE.cfg, 
SE.rul. SE.ptt) and are stored in the Migrate7 shared directory. You must have a 
valid user migration configuration prior to automating with SCCM.  

Tip: You can save user migration templates based on usage and 
have multiple templates in same directory. Ie se.cfg, seLOB1.cfg, 
seLOB2.cfg, etc… 

To configure Migrate7 for each logical group of clients complete the following steps:  
 

1. Double-click the Migrate7 shortcut on your Windows Desktop or open from 
Program Files. The Migrate7 Client opens.  

2. Select Extract Personality view, and click on the Select for Extraction 
tab.  

3. Select the application content, and create any File Rules or Registry Rules. 
Please see the Migrate7 Deployment Guide for more information.  

4. Open the File menu, and click Save to save the configuration file.  

5. Open the File menu, and select Exit.  

This saved configuration can now be used as a point of reference when configuring 
other groups. Leading IT organizations create configuration files for user groups 
based on the application set or image used by each group. 

With the Migrate7 base infrastructure deployment complete you can now integrate 
the solution with SCCM to deploy Migrate7 client agents to target machines; inject 
Migrate7 user state tasks into OSD and MDT task sequences; and improve user 
state backups, restores, and migration activities.   
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Deploying Migrate7 with SCCM 
When using the agent based option with Migrate7 it will be necessary to deploy the 
agent to target clients which can be fully automated using SCCM. The following 
sections describe the prerequisites and step-by-step instructions to deploy the 
Migrate7 agent using SCCM. 

Prerequisites 
The following preparation items are required to successfully integrate and deploy 
Migrate7 with SCCM, they include: 

1. Existing and healthy SCCM infrastructure 

2. Setup of Migrate7 software, Data Store, and user migration template 

3. Administrative permissions to SCCM and Migrate7 

Deployment Step-by-step 
Deploying the Migrate7 agent and managing user profile extractions, backups, and 
restores can all be automated with SCCM. The following information provides step-
by-step guidance to perform the following tasks: 

1. Create Migrate7 agent source file repositories 

2. Create Migrate7 agent package 

3. Create Migrate7 user profile extraction package 

4. Create Migrate7 user profile backup package 

5. Confirming Deployments 

Create Migrate7 Agent Source 
To create the Migrate7 client installation source 

1. Create a directory on your preferred Configuration Manager Server to house 
the Migrate7 client installation files. 

2. Navigate to the Migrate7 User State Data Store folder created during the 
Migrate7 User State Data Store Setup. 

3. Copy ClientInstall.msi, SE.cfg, SE.rul, and SE.ptt to the directory created 
in step one. 

4. Edit se.cfg in notepad.  Ensure the line Data Store Location points to the 
UNC path of your Data Store share (e.g., 
\\servername\Migrate7\personalities). 
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Create Migrate7 Agent Package 
After creating the client source directory using the procedure above, you create the 
SCCM software installation package. An SCCM package contains the files and 
instructions that SCCM uses to distribute the software and advertise the package. 
The Deployment wizard creates the files and instructions, but SCCM must be 
configured to use these files. 

To create a software installation package using SCCM 

1 (Windows XP or Windows Vista/7) Click Start menu ➤All Programs ➤ 
Microsoft System Center ➤ Configuration Manager 2007 ➤ConfigMgr 
Console. 

2 In the Configuration Manager Console window, expand Software Distribution 

3 Right-click Packages ➤ Distribute ➤ Software. 

4 In the Distribute Software wizard, click Next. 

5 In the Package dialog box, select Create a New Package and Program without 
a Definition File. Click Next.  

6 In the Package Identification dialog box, enter the information for Name, 
Version, Publisher, Language and any comments. Click Next. 

7 In the Source Files dialog box, make selections to where SCCM retrieves the 
files and how it manages them. Click Next. 

Note: In this procedure, “Always Obtain Files from a Source 
Directory” was selected. 

8 In the Source Directory dialog box, specify the directory where the client 
source files are stored. Click Next. 

9 In the Distribution Points dialog box, select the distribution point(s). This is 
the location from which the software package will be deployed to the target 
systems. Click Next. 

10 In the Program Identification dialog box, enter the name of your program. 
This is the name that displays in Add or Remove Programs in the Control 
Panel. In the Command Line field, enter msiexec.exe /qn ALLUSERS=2 
APPLICATIONFOLDER=C:\Migrate7Client DESKTOPSHORTCUT=0 /m 
MSIGPSCO /i\\<UNCPath>\tranxition\Migrate7\clientinstall.msi 
Click Next. 

Note: To install for all users use ALLUSERS=1, to install for only 
SCCM service account use ALLUSERS=2 
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11 In the Program Properties dialog box, Program Can Run drop-down list, 
select how you want your program to install. Your choices are: 

 Only When a User is Logged On 

 Whether or Not a User is Logged On 

 Only When No User is Logged On 

12 In the After Running drop-down list, select an action to take after the 
program has deployed. Your choices are: 

 No Action Required 

 Program Restarts Computer 

 ConfigMgr Restarts Computer 

 ConfigMgr Logs User Off 

Click Next. 

13 In the Advertise Program dialog box, select Yes to advertise the program. 
Click Next. 

14 In the Select a Program to Advertise dialog box, select the package you want 
to advertise. Click Next. 

15 In the Select Program ➤ Advertisement Target dialog box, select the 
collection to which you want to advertise, or create a new collection for 
target systems that require the agent. 

16 In the Select Program ➤ Advertisement Name dialog box, enter or change 
the name of your advertisement. Add any comments to further describe the 
advertisement. Click Next. 

17 In the Select Program ➤ Advertisement Subcollection dialog box, select one 
of the following options: 

 Advertise this Program to an Existing Collection 

 Create a New Collection and Advertise this Program to It 

18 Click Next (Assumes previous selection was advertise to existing collection). 

19 In the Select Program ➤ Advertisement Schedule dialog box, if desired, set 
options to advertise your program at a specific date and time, or set 
expiration date. Click Next. 
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20 In the Select Program ➤ Assign Program dialog box, select one of the 
following options: 

 If the installation process is mandatory, select Yes, Assign the 
Program. 

 If the installation process is optional, select No, Do Not Assign the 
Program 

Click Next. 

21.In the Summary dialog box, verify your advertisement information. Use the 
back buttons to make any changes. To finish, click Next. 

The Migrate7 agent installation package and advertisement to deploy package have 
now been completed.  

Once the agent infrastructure is installed users can also elect to automate User 
Profile extraction and restores as well as automating the user migration process 
during OSD and MDT deployments.  

Create User Profile Extraction Package 
After installing the Migrate7 client software using the procedure above, you can 
create an SCCM software distribution program to perform a personality extraction.  

To create an Migrate7 extraction package using SCCM 

1 Click Start menu ➤All Programs ➤ Microsoft System Center ➤ Configuration 
Manager 2007 ➤ConfigMgr Console. 

2 In the Configuration Manager Console window, expand Software Distribution 

3 Right-click Packages ➤ Distribute ➤ Software. 

4 In the Distribute Software wizard, click Next. 

5 In the Package dialog box, select Create a New Package and Program without 
a Definition File. Click Next. 

6 In the Package Identification dialog box, enter the information for Name, 
Version, Publisher, Language and any comments. Click Next. 

7 In the Source Files dialog box, select the option “This package does not 
contain any source files”. Click Next. 

8 In the Program Identification dialog box, enter the name of your program. 
This is the name that displays in Add or Remove Programs in the Control 
Panel. In the Start In field, enter C:\Migrate7Client. In the Command Line 
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field, enter se.exe /autoextract /allusers /hidestatus /nocancel. Click 
Next. 

Note: To override the default Data Store defined in the 
configuration file use the /datastore switch. Ie se.exe /autoextract 
/allusers /hidestatus /nocancel /datastore “\\server\path” 

9 In the Program Properties dialog box, Program Can Run drop-down list, 
select how you want your program to install. Your choices are: 

 Only When a User is Logged On 

 Whether or Not a User is Logged On 

 Only When No User is Logged On 

Note: In this procedure, “Whether or Not a User is Logged On” 
was selected. 

10 In the After Running drop-down list, select an action to take after the 
program has deployed. Your choices are: 

 No Action Required 

 Program Restarts Computer 

 ConfigMgr Restarts Computer 

 ConfigMgr Logs User Off 

Click Next. 

11 In the Advertise Program dialog box, select  Yes to advertise the program. 
Click Next. 

12 In the Select a Program to Advertise dialog box, select the package you want 
to advertise. Click Next. 

13 In the Select Program ➤ Advertisement Target dialog box, select the 
collection to which you want to advertise, or create a new collection. Ensure 
that the collection members have the Migrate7 client installed, else the 
advertisement will fail on those computers. 

14 In the Select Program ➤ Advertisement Name dialog box, enter or change 
the name of your advertisement. Add any comments to further describe the 
advertisement. Click Next. 
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15 In the Select Program ➤ Advertisement Subcollection dialog box, select one 
of the following options: 

 Advertise this Program to an Existing Collection 

 Create a New Collection and Advertise this Program to It 

16 Click Next. 

17 In the Select Program ➤ Advertisement Schedule dialog box, if desired, set 
options to advertise your program at a specific date and time, or set 
expiration date. Click Next. 

18 In the Select Program ➤ Assign Program dialog box, select one of the 
following options: 

 If the installation process is mandatory, select Yes, Assign the 
Program. 

 If the installation process is optional, select No, Do Not Assign the 
Program 

Click Next. 

22.In the Summary dialog box, verify your advertisement information. Use the 
back buttons to make any changes. To finish, click Next. 

Create User Profile Backup Package 
After installing the Migrate7 client software and performing a personality extraction 
using the procedures above, you can create an SCCM software distribution program 
to perform a scheduled personality backup.  

Ensure that the collection you create contain only members who have the Migrate7 
client installed and have performed an initial extraction. 

To create an Migrate7 Personality Backup package using SCCM 

1 Click Start menu ➤All Programs ➤ Microsoft System Center ➤ Configuration 
Manager 2007 ➤ConfigMgr Console. 

2 In the Configuration Manager Console window, expand Software Distribution 

3 Right-click Packages ➤ Distribute ➤ Software. 

4 In the Distribute Software wizard, click Next. 

5 In the Package dialog box, select Create a New Package and Program without 
a Definition File. Click Next. 
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6 In the Package Identification dialog box, enter the information for Name, 
Version, Publisher, Language and any comments. Click Next. 

7 In the Source Files dialog box, select the option “This package does not 
contain any source files”. Click Next. 

8 In the Program Identification dialog box, enter the name of your program. 
This is the name that displays in Add or Remove Programs in the Control 
Panel. In the Start In field, enter C:\Migrate7Client. In the Command Line 
field, enter se.exe /autoextract /allusers /hidestatus /nocancel. Click 
Next. 

9 In the Program Properties dialog box, Program Can Run drop-down list, 
select how you want your program to install. Your choices are: 

 Only When a User is Logged On 

 Whether or Not a User is Logged On 

 Only When No User is Logged On 

Note: In this procedure, “Whether or Not a User is Logged On” 
was selected. 

10 In the After Running drop-down list, select No Action Required as the 
action to take after the program has deployed.  Click Next. 

11 In the Advertise Program dialog box, select Yes to advertise the program. 
Click Next. 

12 In the Select a Program to Advertise dialog box, select the package you want 
to advertise. Click Next. 

13 In the Select Program ➤ Advertisement Target dialog box, select the 
collection to which you want to advertise, or create a new collection. Ensure 
that the collection members have the Migrate7 client installed and have 
performed an initial extraction; else the extraction will fail on those 
computers. 

14 In the Select Program ➤ Advertisement Name dialog box, enter or change 
the name of your advertisement. Add any comments to further describe the 
advertisement. Click Next. 

15 In the Select Program ➤ Advertisement Subcollection dialog box, select one 
of the following options: 
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 Advertise this Program to an Existing Collection. Any existing collection 
selected should include only those machines that have healthy SCCM 
Agents AND the Migrate7 client agent installed. 

 Create a New Collection and Advertise this Program to It 

16 Click Next. 

17 In the Select Program ➤ Advertisement Schedule dialog box, if desired, set 
options to advertise your program at a specific date and time, or set 
expiration date. Click Next. 

18 In the Select Program ➤ Assign Program dialog box, select one of the 
following options: 

 If the installation process is mandatory, select Yes, Assign the 
Program. 

 If the installation process is optional, select No, Do Not Assign the 
Program 

Click Next. 

19 In the Summary dialog box, verify your advertisement information. Use the 
back buttons to make any changes. To finish, click Next. 

To create a recurring schedule for  Migrate7 Personality Backup package 

1 Click Start menu ➤All Programs ➤ Microsoft System Center ➤ Configuration 
Manager 2007 ➤ConfigMgr Console. 

2 In the Configuration Manager Console window, expand Software Distribution 

3 Select Advertisements 

4 In the right pane, right-click your Migrate7 Personality Backup package and 
select Properties. 

5 Select the Schedule tab 

6 Select Assign to the following schedule and click the Schedule button 

7 Enter your desired start time and reoccurrence frequency and click OK twice. 
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Confirming Deployment/s 
The following list summarizes some of the resources and methods available for 
monitoring the Migrate7 agent and package deployment status. 

1. Review Advertisement Status Messages for the Agent Installation, Personality 
Extraction and Backup jobs. Identify any failures.  

2. Review the report “Status of a specific advertisement” 
3. For failed Agent Installation: 

a. Create collection of all machines that failed to install the Migrate 7 
agent and re-run advertisement to install if failed previously. Use the 
advertisement status message as the basis for the collection criteria. 

4. For failed user personality extraction jobs: 
a. Confirm personality extraction process generates success/failure status 

messages 
b. Create status filter query to email technician when personality 

extraction process fails 
c. Identify missing pre-requisites (disk space, Migrate 7.0 agent, etc.) 

5. For failed user backup jobs: 
a. Confirm personality extraction process generates success/failure status 

messages 
b. Create status filter query to email technician when personality 

extraction process fails 
c. Identify missing pre-requisites (disk space, Migrate 7.0 agent, etc.) 

6. For additional logging information on the local machine, go to c:\documents 
and settings\all users\application data\tranxition\migrate 7. Each time a job 
is run, a separate log entry will be created showing the status of the 
extraction and backup process depending on which was run. Also, within the 
personality folder of the data source, a log is also created showing the 
progress made.  
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Deployment Tips 
Managing user profile migrations in medium to large sized business with Migrate7 
requires proper planning of the Data Stores, user migration templates, solution 
usage, and monitoring.   

Migrate7 includes native logging to track user profile extractions, backups, and 
restores which can be used to troubleshoot problem migrations or validate 
migration steps. This is further complemented using DCM IT can validate the 
Migrate7 footprint and configurations throughout the business. 

Migrate7 Agent Logging 
The Migrate7 Log file display can be customized by accessing Preferences through 
the Edit menu and selecting Preferences and the Log File tab. Choose the level of 
log file detail from the drop down field for Error log, Warning log, Informational log, 
Verbose log and Trace log. This setting is saved to the se.cfg file. 
 
Migrate7 logs can be set to be displayed following each extraction, injection or 
personality backup. Uncheck the “display log on completion” check box if this is not 
desired behavior. 
 
The name of the log file contains the computer name and the date and time of the 
extraction, injection, backup, or restore. Log files are located in the personality 
folder of each individual user. 

Assessing Migrate7 with DCM 
Users can add DCM rules to validate Migrate7 installation and status. The following 
setting rule could be added to existing DCM baselines to validate Migrate7 is at the 
correct client version across target machines. 

Registry Rule 

Path: HKEY_LOCAL_MACHINE\SOFTWARE\Tranxition Corporation\Personality 
Tranxport Professional\ 

Key: Version 

Expected Value: >=7.5 

Additional registry values of interest that may want to be monitored are in 
HKLM\Software\Tranxition Corporation\Personality\Transport Professional\Settings 
directory, including last log, location, personalities and plugins. For example the last 
log can be used to determine the last time a backup or extraction was run. 

  

 
Integrating Migrate7 with System Center Configuration Manger 2007 R2                                    Page 21 of 31 



Integrating Migrate7 with SCCM OSD and MDT 
Integrating Migrate7 with your existing OSD and MDT environment provides the 
ability to install the agent client during time of new installations, system refreshes, 
or cloning as well as the option to automatically extract/backup and inject/restore. 
The information below outlines how to integrate Migrate7 tasks with your SCCM 
OSD task sequences. 

Prerequisites 
The following preparation items are required to successfully integrate and deploy 
Migrate7 with SCCM OSD and MDT, they include: 

1. Existing and healthy SCCM infrastructure 

2. Setup of Migrate7 software, Data Store, and user migration template 

3. Administrative permissions to SCCM and Migrate7 

4. Migrate7 agent package created 

Adding Migrate7 client to your existing OSD task sequences 
To add Migrate7 to your existing SCCM OSD deployments use the following steps: 

1 Click Start menu ➤All Programs ➤ Microsoft System Center ➤ Configuration 
Manager 2007 ➤ConfigMgr Console. 

2 In the Configuration Manager Console window, expand Site Database 
➤Computer Management ➤Operating System Deployment ➤Task Sequences 

3 Right-click the Task Sequence you wish to modify and select Edit 

4 On the Task Sequence Editor pane, Click Add ➤General ➤Install Software 

5 On the Properties tab of the new Install Software task sequence, enter the 
desired name and description for the task sequence step. 

6 Select Install a single application, browse to the Migrate 7 agent package 
and select the Silent Install 

7 Ensure the Migrate7 task sequence step is performed after the Apply 
operating system image step. 

The Migrate7 agent installation has now been added to an OSD task sequence. 
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Auto Extract User Profiles Task Sequence – Existing Task Sequence 
To add a Migrate7 user profile extraction task to an existing task sequence follow 
the steps outlined below. 

1 Click Start menu ➤All Programs ➤ Microsoft System Center ➤ Configuration 
Manager 2007 ➤ConfigMgr Console. 

2 In the Configuration Manager Console window, expand Site Database 
➤Computer Management ➤Operating System Deployment ➤Task Sequences 

3 Right-click the Task Sequence you wish to modify and select Edit 

4 On the Task Sequence Editor pane, Click Add ➤General ➤Run Command 
Line 

5 On the Properties tab of the new Run Command Line task sequence, enter 
the desired name and description for the task sequence step. 

6 In the command line box, enter C:\Migrate7Client\se.exe /autoextract 
/ALLUSERS /hidestatus /nocancel 

7 Check the box for Run this step as the following account and set the 
credentials for the applicable administrator account. 

8 Click Apply and OK. 

The Migrate7 user extraction task has now been added to an OSD task sequence. 

Auto Extract User Profiles Task Sequence – New Task Sequence 
To add a Migrate7 user profile extraction task to a new task sequence follow the 
steps outlined below. 

1 Click Start menu ➤All Programs ➤ Microsoft System Center ➤ Configuration 
Manager 2007 ➤ConfigMgr Console. 

2 In the Configuration Manager Console window, expand Site Database 
➤Computer Management ➤Operating System Deployment ➤Task Sequences 

3 Right-click the Task Sequence folder and select New ➤Task Sequence 

4 On the Create New Task Sequence window, select Create a new custom 
task sequence. Click Next. 

5 On the Task Sequence Information screen enter the desired name and 
comment for the task sequence. Click Next to finish. 

6 Edit the task sequence that was just created 

 
Integrating Migrate7 with System Center Configuration Manger 2007 R2                                    Page 23 of 31 



7 On the Task Sequence Editor pane, Click Add ➤General ➤Run Command 
Line 

8 On the Properties tab of the new Run Command Line task sequence, enter 
the desired name and description for the package. 

9 In the command line box, enter C:\Migrate7Client\se.exe /autoextract 
/ALLUSERS /hidestatus /nocancel 

10 Check the box for Run this step as the following account and set the 
credentials for the applicable administrator account. 

11 Click Apply and OK. 

The Migrate7 user extraction task has now been added to a new OSD task 
sequence. 

Auto Inject User Profile Task Sequence – Existing Task Sequence 
To add a Migrate7 user profile injection task to an existing task sequence follow the 
steps outlined below. 

1 Click Start menu ➤All Programs ➤ Microsoft System Center ➤ Configuration 
Manager 2007 ➤ConfigMgr Console. 

2 In the Configuration Manager Console window, expand Site Database 
➤Computer Management ➤Operating System Deployment ➤Task Sequences 

3 Right-click the Task Sequence you wish to modify and select Edit 

4 On the Task Sequence Editor pane, Click Add ➤General ➤Run Command 
Line 

5 On the Properties tab of the new Run Command Line task sequence, enter 
the desired name and description for the package. 

6 In the command line box, enter C:\Migrate7Client\se.exe /autoinject 
/ALLUSERS /hidestatus /nocancel 

7 Check the box for Run this step as the following account and set the 
credentials for the applicable administrator account. 

8 Click Apply and OK. 

The Migrate7 user injection task has now been added to an OSD task sequence. 
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Auto Inject User Profiles Task Sequence – New Task Sequence 
To add a Migrate7 user profile injection task to a new task sequence follow the 
steps outlined below. 

1 Click Start menu ➤All Programs ➤ Microsoft System Center ➤ Configuration 
Manager 2007 ➤ConfigMgr Console. 

2 In the Configuration Manager Console window, expand Site Database 
➤Computer Management ➤Operating System Deployment ➤Task Sequences 

3 Right-click the Task Sequence folder and select New ➤Task Sequence 

4 On the Create New Task Sequence window, select Create a new custom 
task sequence. Click Next. 

5 On the Task Sequence Information screen enter the desired name and 
comment for the task sequence. Click Next to finish. 

6 Edit the task sequence that was just created 

7 On the Task Sequence Editor pane, Click Add ➤General ➤Run Command 
Line 

8 On the Properties tab of the new Run Command Line task sequence, enter 
the desired name and description for the package. 

9 In the command line box, enter C:\Migrate7Client\se.exe /autoinject 
/ALLUSERS /hidestatus /nocancel 

10 Check the box for Run this step as the following account and set the 
credentials for the applicable administrator account. 

11 Click Apply and OK. 

The Migrate7 user injection task has now been added to a new OSD task sequence. 
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Auto Backup User Profile Task Sequence – Existing Task Sequence 
To add a Migrate7 user profile backup task to an existing task sequence follow the 
steps outlined below. 

1 Click Start menu ➤All Programs ➤ Microsoft System Center ➤ Configuration 
Manager 2007 ➤ConfigMgr Console. 

2 In the Configuration Manager Console window, expand Site Database 
➤Computer Management ➤Operating System Deployment ➤Task Sequences 

3 Right-click the Task Sequence you wish to modify and select Edit 

4 On the Task Sequence Editor pane, Click Add ➤General ➤Run Command 
Line 

5 On the Properties tab of the new Run Command Line task sequence, enter 
the desired name and description for the package. 

6 In the command line box, enter C:\Migrate7Client\se.exe 
/AUTOBACKUP /ALLUSERS /hidestatus /nocancel 

7 Check the box for Run this step as the following account and set the 
credentials for the applicable administrator account. 

8 Click Apply and OK. 

The Migrate7 user backup task has now been added to an existing OSD task 
sequence. 

Auto Backup User Profiles Task Sequence – New Task Sequence 
To add a Migrate7 user profile backup task to a newtask sequence follow the steps 
outlined below. 

1 Click Start menu ➤All Programs ➤ Microsoft System Center ➤ Configuration 
Manager 2007 ➤ConfigMgr Console. 

2 In the Configuration Manager Console window, expand Site Database 
➤Computer Management ➤Operating System Deployment ➤Task Sequences 

3 Right-click the Task Sequence folder and select New ➤Task Sequence 

4 On the Create New Task Sequence window, select Create a new custom 
task sequence. Click Next. 

5 On the Task Sequence Information screen enter the desired name and 
comment for the task sequence. Click Next to finish. 

6 Edit the task sequence that was just created 
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7 On the Task Sequence Editor pane, Click Add ➤General ➤Run Command 
Line 

8 On the Properties tab of the new Run Command Line task sequence, enter 
the desired name and description for the package. 

9 In the command line box, enter C:\Migrate7Client\se.exe /autoinject 
/ALLUSERS /hidestatus /nocancel 

10 Check the box for Run this step as the following account and set the 
credentials for the applicable administrator account. 

11 Click Apply and OK. 

The Migrate7 user backup task has now been added to a new OSD task sequence. 
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Advanced User Profile Migration 
When using Migrate7 users have the option to define very granular state migration 
policies and rules to support a broad range of environmental needs. These policies 
and rules are then used with the extraction/injection and backup/restore features to 
enable enterprise management of user profiles. The following information highlights 
some of the potential optimized workflow scenario’s one may want to consider 
when using Migrate7 with SCCM.  

User Extraction and Injection Scenarios 

• Extracting profile for currently logged in user 
• Extracting profile/s for users not logged on 
• Extracting profiles for multiple users 
• Converting user profiles from old to new domain 
• Assigning default passwords 
• Exclude users from profile extraction 
• Excluding unused users from profile extraction 
• Enable profile auto-backup on restore 
• Migrate local and/or domain users 
• Managing migrations with multiple Data Stores  

 

For a full list of Migrate7 automation options and command line switches please 
refer to the Migrate Automation Guide. 

For a full list of Migrate7 configuration options for migration policies and rules 
please refer to the Migrate7 Users Guide. 
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Additional Resources 
The links below are to Migrate7 and SCCM resources that may be of interest or 
useful when integrating the two technologies. 

Migrate 7 Resources 

Migrate7 Deployment Guide 

http://www.tranxition.com/resources/pdf/Migrate7%20Deployment%20Guide.pdf 

Migrate7 Reference Guide for Automating Migrate7 

http://www.tranxition.com/resources/pdf/Automating%20Migrate7.pdf 

Migrate7 Data Migration Using File Rules 

http://www.tranxition.com/resources/pdf/Migrate7%20Rule%20Based%20Migratio
n.pdf  

 

Microsoft Links 

System Center Configuration Manager Home Page 

http://www.microsoft.com/systemcenter/en/us/configuration-manager.aspx  

System Center Configuration Manager TechCenter 

http://technet.microsoft.com/en-us/systemcenter/cm/default.aspx 

Microsoft Deployment Toolkit Accelerator Page 

http://technet.microsoft.com/en-us/solutionaccelerators/dd407791.aspx  
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Command Line Argument Quick Reference 
The following table summarizes the available command line arguments for the 
Migrate7 se.exe application. For detailed information on usage and guidance please 
see the Migrate7 automation guide. 

Argument  Short Description 
/AUTOEXTRACT  The /AUTOEXTRACT command, if used without another supported extraction 

command switch will automatically perform a personality extraction of the user that 
is currently logged on to the computer.  

/AUTOINJECT  If the /AUTOINJECT command is used without another supported injection command, 
the switch will automatically perform a personality injection for the user that is 
currently logged on to the computer.  

/PASSWORD 
<password> 

The /PASSWORD command is used to automatically assign a password to a 
personality during extraction and injection 

/CONFIG “PATH/FILE”  The /CONFIG command‐line argument is used to specify a Configuration file when 
performing an automatic extraction or injection. The form of the argument is: 
/CONFIG "path\file".

/IMPORT  The /IMPORT command‐line argument is used to import a personality. 

/SOURCE  The /SOURCE command is used to specify the Computer name that was associated 
with the extracted personality. This command is typically used in combination with 
the /ALLUSER command line switch and only on Injection.

/INCLUDEUSER  The /INCLUDEUSER command will extract/inject the personalities for each user that is 
specified. 

/ALLUSERS  The /ALLUSERS command will extract/inject all existing users on/from the computer.

/EXCLUDEUSER 
domain\username 
[additional users] 

The /EXCLUDEUSER command allows you to exclude specified users from being 
extracted or injected. 

/EXCLUDELOCAL  The /EXCLUDELOCAL command allows you to exclude local users from being 
extracted.  

/EXCLUDEUNUSED 
<Days> 

The /EXCLUDEUNUSED command allows you to exclude user profiles that have not 
been used in a specified number of days.

/DOMAIN 
olddomain:newdomain 

The /DOMAIN command allows you to redirect injected users from an old domain 
name to a new domain name.

/DATASTORE 
"\\server\personalities
" 

This /DATASTORE command can be used to specify an alternate location for the 
LiveManage data store. The path to the data store is specified following the 
command line switch

/EXCLUDEDISKS 
disk1;disk2;disk3 

This /EXCLUDEDISKS command enables you to specify letters associated with drives 
that you do not want LiveManage to inject data to during the personality injection.

/INJECTTOLOGGEDINU
SER 

This /INJECTTOLOGGEDINUSER command enables you to force an injection of a user's 
personality to the user that is logged on to the target machine even if the username 
does not match the username of the user that is being injected. 

/AUTOBACKUP  The /AutoBackup command allows you to backup changes to a specified personality 
via command line.

/EXCLUDEDOMAIN  The /ExcludeDomain command is used exclude users from being injected or extracted

/NOCANCEL  The /NoCancel command is used to hide the LiveManage cancel button that is 
displayed on the progress bar during extraction.

/HIDESTATUS  The /HideStatus command is used to hide the LiveManage progress bar for extraction 
and injection. 
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